Drush

Composer で Drush を入れようとしたときのエラー

エラー文

Could not parse version constraint ^2.6.3: Invalid version string

原因

Composer のバージョンが古いために起こるエラーのようです。 私は Composer 0.9-dev で Drush 7.0 を入れようとしたときに発生し Drush を入れることができませんでした。

対処方法

Composer をアップデートします。 Composer は self-update コマンドで Composer 自身をアップデートすることができます。

さくらのレンタルサーバーで drush の自動補完がきかない問題の解決方法

さくらインターネットのレンタルサーバーで Drupal を使うときに起こる問題の解決方法についてです。

さくらで Drush をセットアップし自動補完用のスクリプトも読み込むようにしたのに、自動補完がきかないことがあります。 drush コマンドは使えるのに自動補完がきかない、そんな場合には drush コマンド、 drush エイリアスのいずれも認識されていないことが原因の可能性が大きいでしょう。

原因

drush コマンド、 drush エイリアスが認識されていないため。