Composer

Composer で Drush を入れようとしたときのエラー

エラー文

Could not parse version constraint ^2.6.3: Invalid version string

原因

Composer のバージョンが古いために起こるエラーのようです。 私は Composer 0.9-dev で Drush 7.0 を入れようとしたときに発生し Drush を入れることができませんでした。

対処方法

Composer をアップデートします。 Composer は self-update コマンドで Composer 自身をアップデートすることができます。